Ad

Your Requirements Could Not Be Resolved To An Installable Set Of Packages. For Running An Application

- 1 answer

I tried to run this project but get follow error by running composer install as developer said

Loading composer repositories with package information
Installi
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for laravel/framework v5.0.4 -> satisfiable by laravel/framework[v5.0.4].
    - laravel/framework v5.0.4 requires ext-mcrypt * -> the requested PHP extension mcrypt is missing from your system.
  Problem 2
    - laravel/framework v5.0.4 requires ext-mcrypt * -> the requested PHP extension mcrypt is missing from your system.
    - laracasts/flash 1.3.3 requires illuminate/support ~5.0 -> satisfiable by laravel/framework[v5.0.4].
    - Installation request for laracasts/flash 1.3.3 -> satisfiable by laracasts/flash[1.3.3].

composer.json file:

{
    "name": "laravel/laravel",
    "description": "The Laravel Framework.",
    "keywords": ["framework", "laravel"],
    "license": "MIT",
    "type": "project",
    "require": {
        "laravel/framework": "5.0.*",
        "doctrine/dbal": "~2.5",
        "illuminate/html": "~5.0",
        "laracasts/flash": "~1.3"
    },
    "require-dev": {
        "phpunit/phpunit": "~4.0",
        "phpspec/phpspec": "~2.1"
    },
    "autoload": {
        "classmap": [
            "database"
        ],
        "psr-4": {
            "App\\": "app/"
        }
    },
    "autoload-dev": {
        "classmap": [
            "tests/TestCase.php"
        ]
    },
    "scripts": {
        "post-install-cmd": [
            "php artisan clear-compiled",
            "php artisan optimize"
        ],
        "post-update-cmd": [
            "php artisan clear-compiled",
            "php artisan optimize"
        ],
        "post-create-project-cmd": [
            "php -r \"copy('.env.example', '.env');\"",
            "php artisan key:generate"
        ]
    },
    "config": {
        "preferred-install": "dist"
    }
}

Seems the version of Laravel used in this project is dev. Can you please tell me how can I run this project? I've no problem with installing a fresh Laravel.

Ad

Answer

PHP is missing mcrypt extension - install and enable it and it will work.

Ad
source: stackoverflow.com
Ad