Ad

Unable To Install Moltin Cart In Laravel 4.1

- 1 answer

When i am trying to install moltin cart then it showes following error

My composer json code is

{
"name": "laravel/laravel",
"description": "The Laravel Framework.",
"keywords": ["framework", "laravel"],
"license": "MIT",
"require": {
    "laravel/framework": "4.1.*",
    "illuminate/support": "4.1.*",
    "intervention/image": "2.2.*",
    "moltin/laravel-cart": "dev-master"
},
"autoload": {
    "classmap": [
        "app/commands",
        "app/controllers",
        "app/models",
        "app/database/migrations",
        "app/database/seeds",
        "app/tests/TestCase.php"
    ]
},
"scripts": {
    "post-install-cmd": [
        "php artisan optimize"
    ],
    "post-update-cmd": [
        "php artisan clear-compiled",
        "php artisan optimize"
    ],
    "post-create-project-cmd": [
        "php artisan key:generate"
    ]
},
"config": {
    "preferred-install": "dist"
},
"minimum-stability": "dev",
"prefer-stable": true

}

It shows following error

C:\xampp\htdocs\laravel>composer update

Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1
    - Conclusion: don't install laravel/framework v4.1.31
    - Conclusion: don't install laravel/framework v4.1.30
    - Conclusion: don't install laravel/framework v4.1.29
    - Conclusion: don't install laravel/framework v4.1.28
    - Conclusion: don't install laravel/framework v4.1.27
    - Conclusion: don't install laravel/framework v4.1.26
    - Conclusion: don't install laravel/framework v4.1.25
    - Conclusion: don't install laravel/framework v4.1.24
    - Conclusion: don't install laravel/framework v4.1.23
    - Conclusion: don't install laravel/framework v4.1.22
    - Conclusion: don't install laravel/framework v4.1.21
    - Conclusion: don't install laravel/framework v4.1.20
    - Conclusion: don't install laravel/framework v4.1.19
    - Conclusion: don't install laravel/framework v4.1.18
    - Conclusion: don't install laravel/framework v4.1.17
    - Conclusion: don't install laravel/framework v4.1.16
    - Conclusion: don't install laravel/framework v4.1.15
    - Conclusion: don't install laravel/framework v4.1.14
    - Conclusion: don't install laravel/framework v4.1.13
    - Conclusion: don't install laravel/framework v4.1.12
    - Conclusion: don't install laravel/framework v4.1.11
    - Conclusion: don't install laravel/framework v4.1.10
    - Conclusion: don't install laravel/framework v4.1.9
    - Conclusion: don't install laravel/framework v4.1.8
    - Conclusion: don't install laravel/framework v4.1.7
    - Conclusion: don't install laravel/framework v4.1.6
    - Conclusion: don't install laravel/framework v4.1.5
    - Conclusion: don't install laravel/framework v4.1.4
    - Conclusion: don't install laravel/framework v4.1.3
    - Conclusion: don't install laravel/framework v4.1.2
    - Conclusion: don't install laravel/framework v4.1.1
    - Installation request for moltin/laravel-cart dev-master -> satisfiable by
      moltin/laravel-cart[dev-master].
    - Conclusion: don't install laravel/framework v4.1.0
    - Conclusion: remove laravel/framework 4.1.x-dev
    - moltin/laravel-cart dev-master requires laravel/framework ~5.0 -> satisfia
     ble by laravel/framework[5.0.x-dev, 5.1.x-dev, 5.2.x-dev, 5.3.x-dev].
    - Can only install one of: laravel/framework[5.0.x-dev, 4.1.x-dev].
    - Can only install one of: laravel/framework[5.1.x-dev, 4.1.x-dev].
    - Can only install one of: laravel/framework[5.2.x-dev, 4.1.x-dev].
    - Can only install one of: laravel/framework[5.3.x-dev, 4.1.x-dev].
    - Installation request for laravel/framework 4.1.* -> satisfiable by laravel
     /framework[4.1.x-dev, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.13,      
Ad

Answer

There it is, right in the error message:

moltin/laravel-cart dev-master requires laravel/framework ~5.0

Either you update laravel or find a branch of laravel-cart that runs on 4.1. Could be the 4.2 tag

Ad
source: stackoverflow.com
Ad