Specs Satisfying The 'firebase_admob', But They Required A Higher Minimum Deployment Target In Flutter

My Flutter app has stopped working when updated firebase_admob to the newest version with firebase_admob: ^0.11.0+1, maybe it has a conflict between a package of the firebase. I'm trying to build an app for iOS but the flutter run fails because of cocoapods:

I'm just updating two packages of the firebase family to the newest version. The package I'm using:

firebase_admob: ^0.11.0+1
firebase_crashlytics: ^0.4.0+1

This is the output of pod install --repo-update

Updating local specs repositories

CocoaPods 1.10.1 is available.
To update use: `sudo gem install cocoapods`

For more information, see and the CHANGELOG for this version at

Analyzing dependencies
firebase_core: Using Firebase SDK version '7.3.0' defined in 'firebase_core'
firebase_crashlytics: Using Firebase SDK version '7.3.0' defined in 'firebase_core'
[!] CocoaPods could not find compatible versions for pod "firebase_admob":
  In Podfile:
    firebase_admob (from `.symlinks/plugins/firebase_admob/ios`)

Specs satisfying the `firebase_admob (from `.symlinks/plugins/firebase_admob/ios`)` dependency were found, but they required a higher minimum deployment target.

[!] Automatically assigning platform `iOS` with version `9.0` on target `Runner` because no platform was specified. Please specify a platform for this target in your Podfile. See ``.

I have some problems on my iOS device, while it's working perfectly on android. I'm getting an error on pod install

I've tried this using the flutter dev & master channel and have the same issue. I'm currently using master. I've tried removing my Pods folder and re-running pod install but not working anyone

This is the output of flutter doctor -v

[✓] Flutter (Channel stable, 1.22.5, on Mac OS X 10.15.7 19H2 darwin-x64, locale en-GB)
    • Flutter version 1.22.5 at /Users/mac/Development/flutter
    • Framework revision 7891006299 (7 weeks ago), 2020-12-10 11:54:40 -0800
    • Engine revision ae90085a84
    • Dart version 2.10.4

[✓] Android toolchain - develop for Android devices (Android SDK version 30.0.3)
    • Android SDK at /Users/mac/Library/Android/sdk
    • Platform android-30, build-tools 30.0.3
    • Java binary at: /Applications/Android
    • Java version OpenJDK Runtime Environment (build 1.8.0_242-release-1644-b3-6915495)
    • All Android licenses accepted.

[✓] Xcode - develop for iOS and macOS (Xcode 12.0)
    • Xcode at /Applications/
    • Xcode 12.0, Build version 12A7209
    • CocoaPods version 1.10.0

[!] Android Studio (version 4.1)
    • Android Studio at /Applications/Android
    ✗ Flutter plugin not installed; this adds Flutter specific functionality.
    ✗ Dart plugin not installed; this adds Dart specific functionality.
    • Java version OpenJDK Runtime Environment (build 1.8.0_242-release-1644-b3-6915495)

[✓] Connected device (1 available)
    • Paresh’s iPhone (mobile) • 49f62dac6f1da634e5d71981db4d591dc9126e4b • ios • iOS 13.3

! Doctor found issues in 1 category.


To fix CocoaPods compatible versions

With the newer version of firebase sometimes need to run pod update manually, after that it generally found everything it needs to build.

To solve this issue follow the below command

  1. Go to Your_Project_Directory/ios/
  2. pod repo update
  3. rm -f Podfile.lock
  4. pod update
  5. pod install
  6. run flutter run

To fix required a higher minimum deployment target

You just need to update the iOS target in Xcode to at least 10.0. This was the reason for the version bump in all the FlutterFire packages. And Firebase admob works just fine on the latest versions.

BREAKING FEAT: forward port to firebase-ios-sdk v7.3.0.

  • Due to this SDK upgrade, iOS 10 is now the minimum supported version by FlutterFire. Please update your build target version.

To fix it increasing your target version iOS target. To change your

Go to your flutter project. Navigate to ios and open  Podfile file and replace the second line of that file with this:

platform :ios, '12.0' or platform :ios, '10.0’ whatever you prefer of > 10