Problem When Removing Index.php From Url

- 1 answer

dont worry it is not an another how to remove index.php from url question!! :D

i researched and made according to tutorials; here is my source

im sure about all steps, but when run it, i dont see any error message… url changes like

but it always display homepage :/ thats weird!!

what can be problem? any idea?

thanks a lot! appreciate helps!!



if it always displays the home page it could be that your application isn't configured properly.

Check the system/application/config/config.php file and find the $config['uri_protocol'] option.

If you notice, in the comments there are a number of options you can try. I've found that sometimes on different servers I need to try different options before it will work (I think it's something to do with the PHP configuration, the AUTO option doesn't always get it right).