Ad

PhpStorm Xdebug Configuration For Php

- 1 answer

After installing Xdebug on Windows 10 and test that with php --version command I get this output:

C:\xampp\htdocs\instacheeta>php --version
PHP 7.2.4 (cli) (built: Mar 28 2018 04:46:46) ( ZTS MSVC15 (Visual C++ 2017) x86 )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Xdebug v2.7.0alpha1, Copyright (c) 2002-2018, by Derick Rethans

After that I enable debug mode in PhpStorm by clicking on: enter image description here , enabling Firefox XDebug addons: enter image description here and then make break point on PhpStorm I expect that work correctly and stop on my break points.

enter image description here

But there are one problem, when I opening Validate debugger configuration dialog I can't validate debugger configuration

enter image description hereenter image description hereenter image description here

UPDTAE:

enter image description hereenter image description here

My web app work on 8000 port with http://127.0.0.1 IP and my web app folder is in C:\xampp\htdocs\instacheeta path

Ad

Answer

PROBLEM RESOLVE

i cahnged xdebug setting into php.ini to:

zend_extension=xdebug
[XDebug]
xdebug.remote_autostart=1
xdebug.default_enable=1
xdebug.remote_host=127.0.0.1
xdebug.remote_connect_back=1
xdebug.remote_enable =1
xdebug.remote_port=9000
xdebug.idekey=PHPSTORM

and adding PHPSTORM IDE key on PHPStorm settings from settings->PHP->Debug->DBGP

enter image description here

Ad
source: stackoverflow.com
Ad