Ad

Passport Package Installation

- 1 answer

I've just downloaded the laravel 5.8 and I'm trying to install passport, but I'm getting the following composer error:

 Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: remove laravel/framework v5.8.37
    - Conclusion: don't install laravel/framework v5.8.37
    - laravel/passport 8.x-dev requires illuminate/encryption ^6.0|^7.0 -> satisfiable by illuminate/encryption[6.x-dev, 7.x-dev, v6.0.0, v6.0.1, v6.0.2, v6.0.3, v6.0.4, v6.1.0, v6.10.0, v6.11
.
Ad

Answer

Latest version of Laravel Passport dropped support for Laravel 5.8

Dropped support for Laravel 5.8 (654cc09)

Install earlier version

composer require laravel/passport:7.5.1

Reference

Laravel Passport 8.0 changes

Ad
source: stackoverflow.com
Ad