Ad

NPM React PeerDependencies Error

- 1 answer

I tried to install several npm modules related to React but I got a peerDependencies error. The versions seem ok to me:

npm ERR! peerinvalid The package react does not satisfy its siblings' peerDependencies requirements!
npm ERR! peerinvalid Peer [email protected] wants [email protected]^0.14.5
npm ERR! peerinvalid Peer [email protected] wants [email protected]>=0.14.0
npm ERR! peerinvalid Peer [email protected] wants [email protected]^0.14.6
npm ERR! peerinvalid Peer [email protected] wants [email protected]>=0.14.0
npm ERR! peerinvalid Peer [email protected] wants [email protected]^0.13.3

Doesn't [email protected] satisfy all of:

My package.json is:

    {
    "name": "Test",
    "version": "1.0.0",
    "description": "",
    "dependencies": {
        "babel-core": "^6.4.0",
        "babel-loader": "^6.2.1",
        "babel-plugin-transform-react-jsx": "^6.4.0",
        "babel-preset-es2015": "^6.3.13",
        "babel-preset-react": "^6.3.13",
        "babel-preset-stage-0": "^6.3.13",
        "history": "^1.17.0",
        "jquery": "^2.2.0",
        "lodash": "^4.0.0",
        "react": "^0.14.6",
        "react-autosuggest": "^3.3.1",
        "react-bootstrap": "^0.28.2",
        "react-dom": "^0.14.6",
        "react-router": "^2.0.0-rc2",
        "react-router-bootstrap": "^0.20.1",
        "react-switch-button": "^1.1.1",
        "webpack": "^1.12.11"
    }
    }

Did I miss something?

Ad

Answer

^Allows changes that do not modify the left-most non-zero digit in the [major, minor, patch] tuple., so [email protected]^0.13.3 does not match [email protected].

It would however match any 0.13.x version greater than or equal to 0.13.3.

Ad
source: stackoverflow.com
Ad