Ad

Laravelcollective/html Package Installation Issue In Laravel 5.8

- 1 answer

I'm learning Laravel 5 and I want to install laravelcollective/html in Laravel 5.8. I've found (here and somewhere else) couple of ways to do that. But, I've tried them with no success. I'm using XAMPP 3.2.2 as local server on Windows 10.

Solutions I've tried and what I got.

Solution 1

First, I've added this line

"laravelcollective/html": "5.8.*" 

to my composer.json's require array, save it. And, in my project directory, I ran the command

    composer update

Result 1

PS C:\xampp\htdocs\mylaravel> composer update
    Loading composer repositories with package information
    Updating dependencies (including require-dev) 

Above is a copy and paste of my terminal. The process stops at that level.

Solution 2

I've tried to install laravelcollective/html package by running:

    composer require "laravelcollective/html:5.8.*"

In this, I've tried some other arguments with composer require, like:

composer require 'laravelcollective/html:5.8.*' 
composer require "laravelcollective/html:5.8.*" 
composer require "laravelcollective/html:5.8.0" 
composer require 'laravelcollective/html:5.8.0' 
composer require 'laravelcollective/html:^5.8.0' 
composer require "laravelcollective/html:^5.8.0" 

Even an argument whithout indicating the version:

composer require  'laravelcollective/html'

All of them give the same result

Result 2

PS C:\xampp\htdocs\mylaravel> composer require 'laravelcollective/html:^5.8.0'


 [Composer\Downloader\TransportException]
 The "https://packagist.org/p/provider-2019-04%241d52886260d9f0e30a70676feea97a605da410b08fd409cad3de1a04bb47c878.json" file could not be downloaded (HTTP
 /1.1 404 Not Found)

require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]...

image of solution2 result

Any help will be appreciated

Ad

Answer

Try to add this version

"laravelcollective/html": "^5.4.0"

Then perform

composer update
Ad
source: stackoverflow.com
Ad