Ad

Laravel Forge Deploy Error

- 1 answer

Yesterday I deployed successfully on my server. But today I received the following error:

From github.com:
 * branch            master     -> FETCH_HEAD
Already up-to-date.
Loading composer repositories with package information
Installing dependencies from lock file
Nothing to install or update
Generating autoload files
> php artisan clear-compiled
> php artisan optimize
Generating optimized class loader
Compiling common classes


  [PDOException]                                                                          
  SQLSTATE[HY000] [1045] Access denied for user 'forge'@'localhost' (using password: NO)  

I can ssh into my server also I've set my ssh key.

Ad

Answer

I know it is late, maybe still useful for someone else. The problem is you haven't set you .env file.

You are probably using forge, go to Environment tab in your forge server page; Click 'Edit Environment'

paste your old .env file there. Make sure your using right database setting:

DB_HOST=localhost
DB_DATABASE=yourdatabase_name
DB_USERNAME=yourSQLuserName
DB_PASSWORD=yourpassword

These are provided in your forge registration email.

Hope this helps.

Ad
source: stackoverflow.com
Ad