Ad

I Can Not Use Google Fonts And WordPress Flutter

- 1 answer

There is no error when I use Google Fonts alone But when I add WordPress Flutter, I get an error first photo & second photo.


dependencies:
  google_fonts: ^2.0.0
  flutter:
    sdk: flutter

  webview_flutter: ^2.0.4
  flutter_wordpress: ^0.2.1

flutter_wordpress 0.2.1

Ad

Answer

You are getting the error because google_fonts: ^2.0.0 uses http: ^0.13.0 and flutter_wordpress uses http: ^0.12.1+1 so there is a dependency conflict so one solution would be to downgrade google fonts to the most compatibe version

which is google_fonts: ^1.1.2 and that should fix the error.

Also downgrade doesnt mean you are missing on any features the changelog specifies 2.0.0 has only null safety added.

Ad
source: stackoverflow.com
Ad