Ad

How Can I Use Nginx For Load Balancer -simple Node.js With Docker Compose?

- 1 answer

I am googling and trying to use nginx for simple node.js application with docker compose. But when I look at localhost:8081 My request returned me as 502 bad gate way. How can I handle this error?

My file structure below:

enter image description here

Load-Balancer:

DockerFile:

FROM nginx:stable-alpine 
LABEL xxx yyyyyy
COPY nginx.conf /etc/nginx/nginx.conf

EXPOSE 8081
CMD ["nginx", "-g", "daemon off;"]

nginx.conf:

events { worker_connections 1024; }

http {

upstream localhost {
server backend1:3001;
server backend2:3001;
server backend3:3001;
}

server {
listen 8081;
server_name localhost;

location / {
   proxy_pass http://localhost;
   proxy_set_header X-Real-IP $remote_addr;
   proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
   proxy_set_header X-Forwarded-Proto $scheme;
   proxy_set_header Host $http_host;
   proxy_set_header X-NginX-Proxy true;
}
 }
 }

docker-compose.yml


version: '3.2'
services:
  backend1:
      build: ./backend
      tty: true
      volumes:
        - './backend'

  backend2:
      build: ./backend
      tty: true
      volumes:
        - './backend'

  backend3:
      build: ./backend
      tty: true
      volumes:
        - './backend'

  loadbalancer:
      build: ./load-balancer
      tty: true
      links:
          - backend1
          - backend2
          - backend3
      ports:
          - '8081:8081'

volumes:
  backend:

My repository: https://github.com/yusufkaratoprak/nginx_docker_loadbalancer

Ad

Answer

There is no command set for the backend container images to run.

The official nodejs images run node by default, which will start the cli when a tty exists. I assuming the tty was enabled in the compose definition to keep the containers from crashing.

A simple Dockerfile for an app would look like:

FROM node:boron
WORKDIR /app
COPY src/. /app/
RUN npm install
EXPOSE 3001
CMD [ "node", "/app/index.js" ]

A tty shouldn't be needed for most daemons, remove the tty settings from the docker-compose.yml. The links are also redundant in version 2+ compose files.

version: '3.2'
services:
  backend1:
      build: ./backend
      volumes:
        - './backend'

  backend2:
      build: ./backend
      volumes:
        - './backend'

  backend3:
      build: ./backend
      volumes:
        - './backend'

  loadbalancer:
      build: ./load-balancer
      ports:
          - '8081:8081'

volumes:
  backend:
Ad
source: stackoverflow.com
Ad