Ad

Heroku Shopify App After Installation On Shop “The Page You Were Looking For Doesn't Exist.”

After creating and deploying a new shopify app - I've installed it to my shop and after installation it redirected me to home#index page which in my routes.rb for few second and change to another page with 404 - Not found.

First view screen for 2 seconds:screenshot of the website after the first 2 seconds of loading

404 - Not found:

404 not found error

Heroku app logs:

2017-08-31T17:03:15.542454+00:00 app[web.1]: I, [2017-08-31T17:03:15.541990 #4] INFO -- : [b31d1ac2-53c8-4f1d-8c2a-89cb7817bdf9] Started GET "/?hmac=37e4dde7daf5891a1ee93920cdcb02327c0b7f4a44b6d65c601ab08d565a5d49&shop=andreyka.myshopify.com&timestamp=1504198994" for 80.246.140.79 at 2017-08-31 17:03:15 +0000

2017-08-31T17:03:15.550387+00:00 app[web.1]: I, [2017-08-31T17:03:15.550211 #4] INFO -- : [b31d1ac2-53c8-4f1d-8c2a-89cb7817bdf9] Processing by HomeController#index as HTML

2017-08-31T17:03:15.550397+00:00 app[web.1]: I, [2017-08-31T17:03:15.550346 #4] INFO -- : [b31d1ac2-53c8-4f1d-8c2a-89cb7817bdf9] Parameters: {"hmac"=>"37e4dde7daf5891a1ee93920cdcb02327c0b7f4a44b6d65c601ab08d565a5d49", "shop"=>"andreyka.myshopify.com", "timestamp"=>"1504198994"}

2017-08-31T17:03:15.557075+00:00 app[web.1]: D, [2017-08-31T17:03:15.556973 #4] DEBUG -- : [b31d1ac2-53c8-4f1d-8c2a-89cb7817bdf9] [1m[36mShop Load (0.9ms)[0m [1m[34mSELECT "shops".* FROM "shops" WHERE "shops"."id" = $1 LIMIT $2[0m [["id", 1], ["LIMIT", 1]]

2017-08-31T17:03:15.987988+00:00 app[web.1]: I, [2017-08-31T17:03:15.987773 #4] INFO -- : [b31d1ac2-53c8-4f1d-8c2a-89cb7817bdf9] Rendering home/index.html.erb within layouts/embedded_app

2017-08-31T17:03:15.988722+00:00 app[web.1]: I, [2017-08-31T17:03:15.988635 #4] INFO -- : [b31d1ac2-53c8-4f1d-8c2a-89cb7817bdf9] Rendered home/index.html.erb within layouts/embedded_app (0.6ms)

2017-08-31T17:03:15.990684+00:00 app[web.1]: I, [2017-08-31T17:03:15.990595 #4] INFO -- : [b31d1ac2-53c8-4f1d-8c2a-89cb7817bdf9] Rendered layouts/_flash_messages.html.erb (0.2ms)

2017-08-31T17:03:15.991334+00:00 app[web.1]: I, [2017-08-31T17:03:15.991244 #4] INFO -- : [b31d1ac2-53c8-4f1d-8c2a-89cb7817bdf9] Completed 200 OK in 441ms (Views: 5.4ms | ActiveRecord: 0.9ms)

2017-08-31T17:03:15.992454+00:00 heroku[router]: at=info method=GET path="/?hmac=37e4dde7daf5891a1ee93920cdcb02327c0b7f4a44b6d65c601ab08d565a5d49&shop=andreyka.myshopify.com&timestamp=1504198994" host=blackdiamonds.herokuapp.com request_id=b31d1ac2-53c8-4f1d-8c2a-89cb7817bdf9 fwd="80.246.140.79" dyno=web.1 connect=0ms service=459ms status=200 bytes=2738 protocol=https

config.assets.compile = true

Ad

Answer

You should check to see if your app is setup to be an embeded app in Shopify.

You can do this by going to the Shopify Partners website, clicking your app and then going to the "Extensions" tab. If it is setup correctly you should see a disable button in the "Embed in Shopify Admin" section, if it is not then it will say "Enable" and should just need to be clicked.

Shopify app settings

Ad
source: stackoverflow.com
Ad