Ad

Flutter CocoaPods Could Not Find Compatible Version: Cache And BetterPlayer

- 1 answer

I tried to install the pod for Flutter on iOS with CocoaPods but got following error when I started:

[!] CocoaPods could not find compatible version for pod "Cache":
  In Podfile:
    better_player (from ´.symlinks/plugins/better_player/ios´) was resolved to 0.0.1, which depends on
      Cache (-> 6.0.0)

Specs satisfying the ´Cache (-> 6.0.0)´ dependency were found, but they required a higher minimum deployment target.
Ad

Answer

Please Try this steps :

if you have intel chip

  1. flutter clean
  2. update all dependencies to the latest version in pubspec.yml file and do 'get pub'
  3. Go to your Podfile and uncomment #platform :ios, '9.0' Then change the version to 10 platform :ios, '10.0' or higher version
  4. go to ios folder through terminal and do 'pod repo update'
  5. 'pod update' or 'pod install'

if you have M1 chip

  1. flutter clean
  2. update all dependencies to the latest version in pubspec.yml file and do 'get pub'
  3. Go to your Podfile and uncomment #platform :ios, '9.0' Then change the version to 10 platform :ios, '10.0' or higher version
  4. go to ios folder through terminal and do 'arch -x86_64 pod repo update'
  5. 'arch -x86_64 pod update' or 'arch -x86_64 pod install'
Ad
source: stackoverflow.com
Ad