Ad

Firebase Firestore,auth,storage Version Error

I am using using firestore,auth and storage. I know all the versions of them should be same. before:

 implementation 'com.google.firebase:firebase-auth:11.8.0'
implementation 'com.google.firebase:firebase-firestore:11.8.0'
implementation 'com.google.firebase:firebase-storage:11.8.0'

this works fine

but now I have to use

documentReference2.update("test", FieldValue.arrayUnion(documentReference));

So I need to use the newer version of firestore. I tried changing it to 19.0.0,18.0.0,16 etc for all of them. I tried every possible way. But always gives the

error:Failed to resolve: com.google.firebase:firebase-auth:16.0.0 base:firebase-storage:16.0.0 Show in File Show in Project Structure dialog

I'm unable to find a solution

Ad

Answer

Update the following:

 implementation 'com.google.firebase:firebase-auth:11.8.0'
implementation 'com.google.firebase:firebase-firestore:11.8.0'
implementation 'com.google.firebase:firebase-storage:11.8.0'

into this:

 implementation 'com.google.firebase:firebase-auth:17.0.0'
implementation 'com.google.firebase:firebase-firestore:19.0.0'
implementation 'com.google.firebase:firebase-storage:17.0.0'

Check the latest versions here: https://firebase.google.com/support/release-notes/android#latest_sdk_versions

Ad
source: stackoverflow.com
Ad