Ad

Failed To Resolve Com.firebase.firebaseui:firebase-ui-auth:4.3.1

- 1 answer

I have the same problem as many other people with Gradle depencencies resolving...I already checked the other questions but it seems they handle different versions of each library wrt my case...so I decided to ask a new question. This is my app-level build.gradle:

apply plugin: 'com.android.application'

android {
    compileSdkVersion 28
    buildToolsVersion "29.0.0"
    defaultConfig {
        applicationId "..."
        minSdkVersion 19
        targetSdkVersion 28
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android-optimize.txt'), 'proguard-rules.pro'
        }
    }

}

dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
    implementation 'com.android.support:appcompat-v7:28.0.0'
    implementation 'com.android.support:recyclerview-v7:28.0.0'

    implementation 'com.android.support.constraint:constraint-layout:1.1.3'
    implementation 'com.facebook.android:facebook-login:5.1.1'
    implementation 'com.facebook.android:facebook-android-sdk:5.0.0'
    implementation 'com.google.firebase:firebase-auth:16.1.0'
    implementation 'com.google.firebase:firebase-core:16.0.6'
    implementation 'com.google.firebase:firebase-database:16.0.6'

    //the line which causes the error
    implementation 'com.firebase.firebaseui:firebase-ui-auth:4.3.1'

    //these lines are added for handling appcompat error
    implementation 'com.android.support:cardview-v7:28.0.0'
    implementation 'com.android.support:animated-vector-drawable:28.0.0'
    implementation 'com.android.support:customtabs:28.0.0'
    implementation 'com.android.support:support-media-compat:28.0.0'
    implementation 'com.android.support:support-v4:28.0.0'
    implementation 'android.arch.lifecycle:extensions:1.1.1'
    implementation 'com.android.support:design:28.0.0'

    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'com.android.support.test:runner:1.0.2'
    androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'
}

apply plugin: 'com.google.gms.google-services'

and when I add the firebase-ui-auth line, the problem arises. How can I make it work? Furthermore, does someone know if there exists a web page where all the dependencies schemes are grouped? Thanks in advance.

Ad

Answer

To solve this, please change the following line of code:

implementation 'com.firebase.firebaseui:firebase-ui-auth:4.3.1'

to

implementation 'com.firebaseui:firebase-ui-auth:4.3.1'

But I recommend you use the latest version which is 5.0.0. Please see more details about Firebase-UI library.

Ad
source: stackoverflow.com
Ad