Error In Pod Install: CocoaPods Could Not Find Compatible Versions For Pod "FirebaseFirestore"

- 1 answer

[email protected] ios % pod install    
Analyzing dependencies
Pre-downloading: `FirebaseFirestore` from ``, tag `7.3.0`
cloud_firestore: Using Firebase SDK version '8.0.0' defined in 'firebase_core'
firebase_core: Using Firebase SDK version '8.0.0' defined in 'firebase_core'
[!] CocoaPods could not find compatible versions for pod "FirebaseFirestore":
  In Podfile:
    FirebaseFirestore (from ``, tag `7.3.0`)

    cloud_firestore (from `.symlinks/plugins/cloud_firestore/ios`) was resolved to 2.2.1, which depends on
      Firebase/Firestore (= 8.0.0) was resolved to 8.0.0, which depends on
        FirebaseFirestore (~> 8.0.0)

I am getting this error when I executed the pod install command, I deleted the podfile.lock file and executed the command, but this is showing the error with respect to Firebase.

can anyone help me on this issue? Thanks.



This issue is resolved, I just changed the tag as 8.0.0

pod 'FirebaseFirestore', :git => '', :tag => '8.0.0'