Error downloading Lumen via Composer

- 1 answer

Ad

I just updated my Laravel version to 5.2 as well as updating my composer. Then when I tried to install Lumen via composer, I am getting an error of:

Your requirements could not be resolved to an installable set of packages.

Problem 1 - Conclusion: don't install laravel/lumen-installer v1.0.1 - Conclusion: remove symfony/process v3.0.0 - Installation request for laravel/lumen-installer ^1.0 -> satisfiable by laravel/lumen-installer[v1.0.0, v1.0.1]. - Conclusion: don't install symfony/process v3.0.0 - laravel/lumen-installer v1.0.0 requires symfony/process ~2.3 -> satisfiable by symfony/process[v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.2, v2.7.3, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.8.0].

  • Can only install one of: symfony/process[v2.3.0, v3.0.0].
  • Can only install one of: symfony/process[v2.3.1, v3.0.0].
  • ...
  • Installation request for symfony/process == 3.0.0.0 -> satisfiable by symfony/process[v3.0.0].

Installation failed, reverting ./composer.json to its original content.

I just ran this command on my command line base on what is stated on the documentation:

composer global require "laravel/lumen-installer=~1.0"
Ad

Answer

Ad

My guess would be that you have already added a package globally that used symfony/process ~3.0.0 but Lumen installer requires symfony/process ~2.3 so composer cannot install both.

You can either try to resolve this yourself by removing that package and installing Lumen installer globally, add the installer to your working directory (i.e. leave out the global keyword and you should be able to use it in that directory) or Lumen provides a way to install itself directly, by simply running:

composer create-project laravel/lumen YourProjectName --prefer-dist

in your installation directory.

Ad
source: stackoverflow.com
Ad