Ad

Does Laravel 4.2 And 5.2 Supports PHP 7?

- 1 answer

I am working on project which was created using Laravel 4.2 and i am curious to know, if Laravel 4.2 and Laravel 5.2 , supports PHP 7 or not ?

Thanks

Ad

Answer

Update: Starting from 4.2.20 Laravel supports PHP7

@laravelphp tweet:

A special release of Laravel 4.2 has been made (4.2.20) to provide PHP 7 support. Also updates base Symfony components to 2.7.


From one of Laravel issues:

Laravel 5.1 is the first version of Laravel to support PHP 7.

and

Laravel 4.2, and the related symfony version will never get PHP 7 support.

Graham Campbell is the main Laravel contributor after Taylor Otwell, so this info is pretty reliable.

Ad
source: stackoverflow.com
Ad