Composer Returns Nothing To Update While Trying To Update Sentry-laravel Package

I'm trying to update the sentry-laravel package because we are using version 0.10.0 while the version 1.4.1 it is available.

I've searched about the composer update command and found that you should only use composer update vendor/package or composer update vendor/package --with-dependencies so I did it and in the end I received the message: Nothing to update.

I don't know if I am doing something wrong but I don't think so...

We're using Laravel 5.6 and I am using Composer 1.9.0

The composer.json file:

"require": {
        "php": "^7.1.3",
        "ext-gd": "*",
        "aws/aws-sdk-php": "^3.55",
        "bacon/bacon-qr-code": "1.0.3",
        "barryvdh/laravel-dompdf": "^0.8.3",
        "doctrine/dbal": "^2.8",
        "fideloper/proxy": "~4.0",
        "fzaninotto/faker": "^1.4",
        "guzzlehttp/guzzle": "^6.3",
        "jenssegers/agent": "^2.6",
        "laravel/framework": "5.6.*",
        "laravel/homestead": "^7.3",
        "laravel/tinker": "^1.0",
        "league/csv": "^9.0",
        "league/flysystem-aws-s3-v3": "^1.0",
        "maatwebsite/excel": "^3.1",
        "plivo/php-sdk": "^4.0",
        "pragmarx/google2fa-laravel": "^0.2.0",
        "sentry/sentry-laravel": "^0.10.0",
        "simplesoftwareio/simple-qrcode": "~2",
        "spatie/laravel-permission": "^2.12"
    "require-dev": {
        "barryvdh/laravel-debugbar": "^3.2",
        "beyondcode/laravel-dump-server": "^1.2",
        "beyondcode/laravel-query-detector": "^1.0",
        "filp/whoops": "^2.0",
        "imanghafoori/laravel-anypass": "^1.0",
        "mockery/mockery": "^1.0",
        "nunomaduro/collision": "^2.0",
        "phpunit/phpunit": "^7.0"

Anyone have been through this sometime?



You can't update to the latest version because it's incompatible with Laravel 5.6

From the package's readme

Laravel Version Compatibility

  • Laravel 4.2.x is supported until version 0.8.x
  • Laravel <= 5.7.x on PHP <= 7.0 is supported until version 0.11.x
  • Laravel >= 5.x.x on PHP >= 7.1 is supported in the most recent version
  • Laravel >= 6.x.x on PHP >= 7.2 is supported in the most recent version

So you have to update Laravel as well if you want to update the package

Hope this helps