composer install : Your requirements could not be resolved to an installable set of packages

- 1 answer

Ad

might be repeated question. Tried the old one.

I'm getting the error composer install : Your requirements could not be resolved to an installable set of packages

my composer.json is

    "require": {
    "laravel/framework": "4.2.*",
    "laravelbook/ardent": "dev-master",
    "ollieread/multiauth": "dev-master",
    "intervention/image": "2.*",
    "yajra/laravel-datatables-oracle": "~3.0",   
    "barryvdh/laravel-dompdf": "0.4.*",
    "mnshankar/CSV": "1.8"
},

the error i'm getting,

      Problem 1
- Conclusion: don't install laravel/framework v5.1.26
- Conclusion: don't install illuminate/validation v5.1.25
- Conclusion: don't install illuminate/filesystem v4.2.17
- Conclusion: don't install illuminate/validation v5.1.22
- Conclusion: don't install illuminate/filesystem v4.2.16
- Conclusion: don't install illuminate/validation v5.1.20
- Conclusion: don't install illuminate/filesystem v4.2.12
- Conclusion: don't install illuminate/validation v5.1.16
- Conclusion: don't install illuminate/filesystem v4.2.9
- Conclusion: don't install illuminate/filesystem v4.2.8
- Conclusion: don't install illuminate/validation v5.1.13
- Conclusion: don't install illuminate/filesystem v4.2.7
- Conclusion: don't install illuminate/validation v5.1.8
- Conclusion: don't install illuminate/filesystem v4.2.6
- Conclusion: don't install illuminate/validation v5.1.6
- Conclusion: don't install illuminate/filesystem v4.2.5
- Conclusion: don't install illuminate/validation v5.1.2
- Conclusion: don't install illuminate/filesystem v4.2.4
- Conclusion: don't install illuminate/filesystem v4.2.3
- Conclusion: don't install illuminate/filesystem v4.2.2
- Conclusion: don't install illuminate/filesystem v4.2.1
- Conclusion: don't install illuminate/filesystem v4.1.30
- Conclusion: don't install illuminate/filesystem v4.1.29
- Conclusion: don't install illuminate/filesystem v4.1.28
- Conclusion: don't install illuminate/filesystem v4.1.27
- Conclusion: don't install illuminate/filesystem v4.1.26
- Conclusion: don't install illuminate/filesystem v4.1.25
- Conclusion: don't install illuminate/filesystem v4.1.24
- Conclusion: don't install illuminate/filesystem v4.1.23
- Conclusion: don't install illuminate/filesystem v4.1.22
- Conclusion: don't install illuminate/filesystem v4.1.21
- Conclusion: don't install illuminate/filesystem v4.1.20
- Conclusion: don't install illuminate/filesystem v4.1.19
- Conclusion: don't install illuminate/filesystem v4.1.18
- Conclusion: don't install illuminate/filesystem v4.1.17
- Conclusion: don't install illuminate/filesystem v4.1.16
- Conclusion: don't install illuminate/filesystem v4.1.15
- Conclusion: don't install illuminate/filesystem v4.1.14
- Conclusion: don't install illuminate/filesystem v4.1.13
- Conclusion: don't install illuminate/filesystem v4.1.12
- Conclusion: don't install illuminate/filesystem v4.1.11
- Conclusion: don't install illuminate/filesystem v4.1.10
- Conclusion: don't install illuminate/filesystem v4.1.9
- Conclusion: don't install illuminate/filesystem v4.1.8
- Conclusion: don't install illuminate/filesystem v4.1.7
- Conclusion: don't install illuminate/filesystem v4.1.6
- Conclusion: don't install illuminate/filesystem v4.1.5
- Conclusion: don't install illuminate/filesystem v4.1.4
- Conclusion: don't install illuminate/filesystem v4.1.3
    - Installation request for laravelbook/ardent dev-master -> satisfiable by laravelbook/ardent[dev-master].
- Conclusion: don't install illuminate/filesystem v4.1.2
- Installation request for ollieread/multiauth dev-master -> satisfiable by ollieread/multiauth[dev-master].
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.0
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.1
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.10
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.11
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.12
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.13
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.14
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.15
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.16
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.17
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.18
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.19
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.2
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.20
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.21
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.22
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.23
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.24
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.25
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.3
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.4
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.5
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.6
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.7
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.8
- don't install illuminate/filesystem v4.1.0|don't install laravel/framework v5.1.9
- ollieread/multiauth dev-master requires illuminate/filesystem ~4.1|~4.2 -> satisfiable by illuminate/filesystem[v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.13, v4.1.14, v4.1.15, v4.1.16, v4.1.17, v4.1.18, v4.1.19, v4.1.2, v4.1.20, v4.1.21, v4.1.22, v4.1.23, v4.1.24, v4.1.25, v4.1.26, v4.1.27, v4.1.28, v4.1.29, v4.1.3, v4.1.30, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9, v4.2.1, v4.2.12, v4.2.16, v4.2.17, v4.2.2, v4.2.3, v4.2.4, v4.2.5, v4.2.6, v4.2.7, v4.2.8, v4.2.9].
- Conclusion: don't install illuminate/filesystem v4.1.1
- Installation request for laravel/framework 5.1.* -> satisfiable by laravel/framework[v5.1.0, v5.1.1, v5.1.10, v5.1.11, v5.1.12, v5.1.13, v5.1.14, v5.1.15, v5.1.16, v5.1.17, v5.1.18, v5.1.19, v5.1.2, v5.1.20, v5.1.21, v5.1.22, v5.1.23, v5.1.24, v5.1.25, v5.1.26, v5.1.3, v5.1.4, v5.1.5, v5.1.6, v5.1.7, v5.1.8, v5.1.9].
- laravelbook/ardent dev-master requires illuminate/validation ~5.1 -> satisfiable by laravel/framework[v5.1.0, v5.1.1, v5.1.10, v5.1.11, v5.1.12, v5.1.13, v5.1.14, v5.1.15, v5.1.16, v5.1.17, v5.1.18, v5.1.19, v5.1.2, v5.1.20, v5.1.21, v5.1.22, v5.1.23, v5.1.24, v5.1.25, v5.1.26, v5.1.3, v5.1.4, v5.1.5, v5.1.6, v5.1.7, v5.1.8, v5.1.9], illuminate/validation[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22, v5.1.25, v5.1.6, v5.1.8].
- Conclusion: don't install illuminate/validation v5.1.1|install laravel/framework v5.1.25

I'm facing problem in finding which doesn't compatible with?

Ad

Answer

Ad

laravel-ardent/ardent package requires Laravel 5.1.

There's two ways to resolve this conflict:

1. Upgrade Laravel to 5.1 (highly recommend this one!):

"laravel/framework": "5.1.*", 

2. Downgrade laravel-ardent/ardent to v2.1.0 as it works with Laravel 4.0:

"laravelbook/ardent": "2.1.0",
Ad
source: stackoverflow.com
Ad