Ad

Composer Install Horizon Error Don't Install Illuminate/queue

- 1 answer

I want to install horizon in my laravel. When I run

composer require laravel/horizon

But errors happen.

  Problem 1
    - Installation request for laravel/horizon 3.2 -> satisfiable by laravel/horizon[v3.2.0].
    - Conclusion: remove laravel/framework v5.5.48
    - Conclusion: don't install laravel/framework v5.5.48
    - laravel/horizon v3.2.0 requires illuminate/queue ~5.7.0|~5.8.0|~5.9.0 -> satisfiable by illuminate/queue[5.7.17, 5.7.18, 5.7.19, v5.7.0, v5.7.1, v5.7.10, v5.7.11, v5.7.15, v5.7.2, v5.7.20, v5.7.21, v5.7.22, v5.7.23, v5.7.26, v5.7.27, v5.7.28, v5.7.3, v5.7.4, v5.7.5, v5.7.6, v5.7.7, v5.7.8, v5.7.9, v5.8.0, v5.8.11, v5.8.12, v5.8.14, v5.8.15, v5.8.17, v5.8.18, v5.8.19, v5.8.2, v5.8.20, v5.8.22, v5.8.24, v5.8.27, v5.8.28, v5.8.29, v5.8.3, v5.8.30, v5.8.31, v5.8.32, v5.8.33, v5.8.34, v5.8.35, v5.8.4, v5.8.8, v5.8.9].
    - don't install illuminate/queue 5.7.17|don't install laravel/framework v5.5.48
    - don't install illuminate/queue 5.7.18|don't install laravel/framework v5.5.48
    - don't install illuminate/queue 5.7.19|don't install laravel/framework v5.5.48
    - don't install illuminate/queue v5.7.0|don't install laravel/framework v5.5.48
    - don't install illuminate/queue v5.7.1|don't install laravel/framework v5.5.48
    - don't install illuminate/queue v5.7.10|don't install laravel/framework v5.5.48
    - don't install illuminate/queue v5.7.11|don't install laravel/framework v5.5.48
    - don't install illuminate/queue v5.7.15|don't install laravel/framework v5.5.48
    - don't install illuminate/queue v5.7.2|don't install laravel/framework v5.5.48
    - don't install illuminate/queue v5.7.20|don't install laravel/framework v5.5.48
    - don't install illuminate/queue v5.7.21|don't install laravel/framework v5.5.48
    ... ...
    - don't install illuminate/queue v5.8.9|don't install laravel/framework v5.5.48
    - Installation request for laravel/framework (locked at v5.5.48, required as 5.5.*) -> satisfiable by laravel/framework[v5.5.48].

I don't want to update laravel/framework version, what can I do?

Ad

Answer

From version 3.0 Laravel Horizon requires Laravel ~5.7. You can use the lastest version of Horizon 2 if you want to work with Laravel 5.5:

composer require laravel/horizon:2.2.2

See the requirements on packagist.

Ad
source: stackoverflow.com
Ad