Ad

Compile Error : KFirLoggerSwizzler Refrenced From

I am getting this error :

enter image description here

My Pods File sdk's versions are these :

enter image description here

Clearly Firebase pods are greater than 5.0. Peoples are mentioning this issue was in firebase 4.0 pods only but i am still facing this .

Build active architetures only is set to No.

I removed the deprecated google pod and now my podfile.lock looks like this. But issue is still there.

enter image description here

Let me know if i need to add anything else.

Ad

Answer

In the Podfile, remove the Firebase version specifier.

Alternatively, change the Firebase version specifier to lock to minor releases with ~> 5.0 instead the current locking to patch updates with ~> 5.0.0.

It seems that not all of the Firebase components properly updated their version dependency specifiers since the Firebase 5.0.1 release. It looks like your Podfile is locking to a 5.0.x patch release which exposes the issue for you.

If you're still having trouble, share the Podfile.

Ad
source: stackoverflow.com
Ad