Ad

Cocoapods Firebase Pods Update

- 1 answer

Good morning, i have a problem with updating my Firebase/Analytics and Firebase/Core pod.

My Podfile:

source 'https://github.com/CocoaPods/Specs.git'
source 'https://github.com/CocoaPods/Specs'
platform :ios, '10.0'

target 'Unity-iPhone' do
pod 'Firebase/Analytics', '5.15.0'
pod 'Firebase/Core', '5.15.0'
pod 'Firebase/Messaging', '5.1.0'
pod 'GoogleAppMeasurement', '5.3.0'
pod 'Google-Mobile-Ads-SDK', '~> 7.0'
end

if i run pod install i get the following output

Analyzing dependencies

[!] CocoaPods could not find compatible versions for pod "Firebase/Analytics":
  In Podfile:
    Firebase/Analytics (= 5.15.0)

None of your spec sources contain a spec satisfying the dependency: `Firebase/Analytics (= 5.15.0)`.

You have either:
 * out-of-date source repos which you can update with `pod repo update` or with `pod install --repo-update`.
 * mistyped the name or version.
 * not added the source repo that hosts the Podspec to your Podfile.

Note: as of CocoaPods 1.0, `pod repo update` does not happen on `pod install` by default.

with pod outdated: with <code>pod outdated</code>

so i run pod update: so i run <code>pod update</code>

But 'Firebase/Analytics' remains on version 5.1.0 Where am i wrong? i have already try to install repo master several times and also gem

Ad

Answer

As the message says, you should do pod repo update first then do pod update after. Hope this helps.

Ad
source: stackoverflow.com
Ad