Ad

Cannot Install Pip Install Pyautogui, Error Code 1

- 1 answer

pip install <package> command is working for me, I tried installing selenium package it is working in my setup but when I try to install pyautogui, it does not work. Screenshots below. What could be wrong here:

WORKS: enter image description here

DOES NOT WORK, Error:

←[31mCommand "python setup.py egg_info" failed with error code 1 in c:\users\homepc\appdata\local\temp\pip-build-q631su\pyscreeze←[0m

enter image description here

Ad

Answer

The error message is just as it reads. You need the Pillow port of the PIL library as a dependency:

pip install Pillow # a popular port of the Python Imaging Library, which is needed here
Ad
source: stackoverflow.com
Ad