Ad

Cannot Install Global Homestead: Your Requirements Could Not Be Resolved

- 1 answer

I am trying to install homestead on OSX 10.11. I want to be up and running building laravel applications. I cannot run homestead from the command line. When I try to install it globally I get an error:

$ composer global require "laravel/homestead=~2.0"
Changed current directory to /Users/connorleech/.composer
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install laravel/homestead v2.1.8
    - Conclusion: don't install laravel/homestead v2.1.7
    - Conclusion: don't install laravel/homestead v2.1.6
    - Conclusion: don't install laravel/homestead v2.1.5
    - Conclusion: don't install laravel/homestead v2.1.4
    - Conclusion: don't install laravel/homestead v2.1.3
    - Conclusion: don't install laravel/homestead v2.1.2
    - Conclusion: don't install laravel/homestead v2.1.1
    - Conclusion: don't install laravel/homestead v2.1.0
    - Conclusion: don't install laravel/homestead v2.0.17
    - Conclusion: don't install laravel/homestead v2.0.16
    - Conclusion: don't install laravel/homestead v2.0.15
    - Conclusion: don't install laravel/homestead v2.0.14
    - Conclusion: don't install laravel/homestead v2.0.13
    - Conclusion: don't install laravel/homestead v2.0.12
    - Conclusion: don't install laravel/homestead v2.0.11
    - Conclusion: don't install laravel/homestead v2.0.10
    - Conclusion: don't install laravel/homestead v2.0.9
    - Conclusion: don't install laravel/homestead v2.0.8
    - Conclusion: don't install laravel/homestead v2.0.7
    - Conclusion: don't install laravel/homestead v2.0.6
    - Conclusion: don't install laravel/homestead v2.0.5
    - Conclusion: don't install laravel/homestead v2.0.4
    - Conclusion: don't install laravel/homestead v2.0.3
    - Conclusion: don't install laravel/homestead v2.0.2
    - Conclusion: don't install laravel/homestead v2.0.1
    - Conclusion: remove symfony/console v3.0.1
    - Installation request for laravel/homestead ~2.0 -> satisfiable by laravel/homestead[v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.12, v2.0.13, v2.0.14, v2.0.15, v2.0.16, v2.0.17, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8].
    - Conclusion: don't install symfony/console v3.0.1
    - laravel/homestead v2.0.0 requires symfony/console ~2.0 -> satisfiable by symfony/console[2.0.4, 2.0.5, 2.0.6, 2.0.7, v2.0.10, v2.0.12, v2.0.13, v2.0.14, v2.0.15, v2.0.16, v2.0.17, v2.0.18, v2.0.19, v2.0.20, v2.0.21, v2.0.22, v2.0.23, v2.0.24, v2.0.25, v2.0.9, v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.2, v2.7.3, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.8.0, v2.8.1].
    - Can only install one of: symfony/console[v2.3.0, v3.0.1].
    - Can only install one of: symfony/console[v2.3.1, v3.0.1].
    - Can only install one of: symfony/console[v2.3.10, v3.0.1].
    - Can only install one of: symfony/console[v2.3.11, v3.0.1].
    - Can only install one of: symfony/console[v2.3.12, v3.0.1].
    - Can only install one of: symfony/console[v2.3.13, v3.0.1].
    - Can only install one of: symfony/console[v2.3.14, v3.0.1].
    - Can only install one of: symfony/console[v2.3.15, v3.0.1].
    - Can only install one of: symfony/console[v2.3.16, v3.0.1].
    - Can only install one of: symfony/console[v2.3.17, v3.0.1].
    - Can only install one of: symfony/console[v2.3.18, v3.0.1].
    - Can only install one of: symfony/console[v2.3.19, v3.0.1].
    - Can only install one of: symfony/console[v2.3.2, v3.0.1].
    - Can only install one of: symfony/console[v2.3.20, v3.0.1].
    - Can only install one of: symfony/console[v2.3.21, v3.0.1].
    - Can only install one of: symfony/console[v2.3.22, v3.0.1].
    - Can only install one of: symfony/console[v2.3.23, v3.0.1].
    - Can only install one of: symfony/console[v2.3.24, v3.0.1].
    - Can only install one of: symfony/console[v2.3.25, v3.0.1].
    - Can only install one of: symfony/console[v2.3.26, v3.0.1].
    - Can only install one of: symfony/console[v2.3.27, v3.0.1].
    - Can only install one of: symfony/console[v2.3.28, v3.0.1].
    - Can only install one of: symfony/console[v2.3.29, v3.0.1].
    - Can only install one of: symfony/console[v2.3.3, v3.0.1].
    - Can only install one of: symfony/console[v2.3.30, v3.0.1].
    - Can only install one of: symfony/console[v2.3.31, v3.0.1].
    - Can only install one of: symfony/console[v2.3.32, v3.0.1].
    - Can only install one of: symfony/console[v2.3.33, v3.0.1].
    - Can only install one of: symfony/console[v2.3.34, v3.0.1].
    - Can only install one of: symfony/console[v2.3.35, v3.0.1].
    - Can only install one of: symfony/console[v2.3.36, v3.0.1].
    - Can only install one of: symfony/console[v2.3.4, v3.0.1].
    - Can only install one of: symfony/console[v2.3.5, v3.0.1].
    - Can only install one of: symfony/console[v2.3.6, v3.0.1].
    - Can only install one of: symfony/console[v2.3.7, v3.0.1].
    - Can only install one of: symfony/console[v2.3.8, v3.0.1].
    - Can only install one of: symfony/console[v2.3.9, v3.0.1].
    - Can only install one of: symfony/console[v2.4.0, v3.0.1].
    - Can only install one of: symfony/console[v2.4.1, v3.0.1].
    - Can only install one of: symfony/console[v2.4.10, v3.0.1].
    - Can only install one of: symfony/console[v2.4.2, v3.0.1].
    - Can only install one of: symfony/console[v2.4.3, v3.0.1].
    - Can only install one of: symfony/console[v2.4.4, v3.0.1].
    - Can only install one of: symfony/console[v2.4.5, v3.0.1].
    - Can only install one of: symfony/console[v2.4.6, v3.0.1].
    - Can only install one of: symfony/console[v2.4.7, v3.0.1].
    - Can only install one of: symfony/console[v2.4.8, v3.0.1].
    - Can only install one of: symfony/console[v2.4.9, v3.0.1].
    - Can only install one of: symfony/console[v2.5.0, v3.0.1].
    - Can only install one of: symfony/console[v2.5.1, v3.0.1].
    - Can only install one of: symfony/console[v2.5.10, v3.0.1].
    - Can only install one of: symfony/console[v2.5.11, v3.0.1].
    - Can only install one of: symfony/console[v2.5.12, v3.0.1].
    - Can only install one of: symfony/console[v2.5.2, v3.0.1].
    - Can only install one of: symfony/console[v2.5.3, v3.0.1].
    - Can only install one of: symfony/console[v2.5.4, v3.0.1].
    - Can only install one of: symfony/console[v2.5.5, v3.0.1].
    - Can only install one of: symfony/console[v2.5.6, v3.0.1].
    - Can only install one of: symfony/console[v2.5.7, v3.0.1].
    - Can only install one of: symfony/console[v2.5.8, v3.0.1].
    - Can only install one of: symfony/console[v2.5.9, v3.0.1].
    - Can only install one of: symfony/console[v2.6.0, v3.0.1].
    - Can only install one of: symfony/console[v2.6.1, v3.0.1].
    - Can only install one of: symfony/console[v2.6.10, v3.0.1].
    - Can only install one of: symfony/console[v2.6.11, v3.0.1].
    - Can only install one of: symfony/console[v2.6.12, v3.0.1].
    - Can only install one of: symfony/console[v2.6.2, v3.0.1].
    - Can only install one of: symfony/console[v2.6.3, v3.0.1].
    - Can only install one of: symfony/console[v2.6.4, v3.0.1].
    - Can only install one of: symfony/console[v2.6.5, v3.0.1].
    - Can only install one of: symfony/console[v2.6.6, v3.0.1].
    - Can only install one of: symfony/console[v2.6.7, v3.0.1].
    - Can only install one of: symfony/console[v2.6.8, v3.0.1].
    - Can only install one of: symfony/console[v2.6.9, v3.0.1].
    - Can only install one of: symfony/console[v2.7.0, v3.0.1].
    - Can only install one of: symfony/console[v2.7.1, v3.0.1].
    - Can only install one of: symfony/console[v2.7.2, v3.0.1].
    - Can only install one of: symfony/console[v2.7.3, v3.0.1].
    - Can only install one of: symfony/console[v2.7.4, v3.0.1].
    - Can only install one of: symfony/console[v2.7.5, v3.0.1].
    - Can only install one of: symfony/console[v2.7.6, v3.0.1].
    - Can only install one of: symfony/console[v2.7.7, v3.0.1].
    - Can only install one of: symfony/console[v2.7.8, v3.0.1].
    - Can only install one of: symfony/console[v2.8.0, v3.0.1].
    - Can only install one of: symfony/console[v2.8.1, v3.0.1].
    - Can only install one of: symfony/console[2.0.4, v3.0.1].
    - Can only install one of: symfony/console[2.0.5, v3.0.1].
    - Can only install one of: symfony/console[2.0.6, v3.0.1].
    - Can only install one of: symfony/console[2.0.7, v3.0.1].
    - Can only install one of: symfony/console[v2.0.10, v3.0.1].
    - Can only install one of: symfony/console[v2.0.12, v3.0.1].
    - Can only install one of: symfony/console[v2.0.13, v3.0.1].
    - Can only install one of: symfony/console[v2.0.14, v3.0.1].
    - Can only install one of: symfony/console[v2.0.15, v3.0.1].
    - Can only install one of: symfony/console[v2.0.16, v3.0.1].
    - Can only install one of: symfony/console[v2.0.17, v3.0.1].
    - Can only install one of: symfony/console[v2.0.18, v3.0.1].
    - Can only install one of: symfony/console[v2.0.19, v3.0.1].
    - Can only install one of: symfony/console[v2.0.20, v3.0.1].
    - Can only install one of: symfony/console[v2.0.21, v3.0.1].
    - Can only install one of: symfony/console[v2.0.22, v3.0.1].
    - Can only install one of: symfony/console[v2.0.23, v3.0.1].
    - Can only install one of: symfony/console[v2.0.24, v3.0.1].
    - Can only install one of: symfony/console[v2.0.25, v3.0.1].
    - Can only install one of: symfony/console[v2.0.9, v3.0.1].
    - Can only install one of: symfony/console[v2.1.0, v3.0.1].
    - Can only install one of: symfony/console[v2.1.1, v3.0.1].
    - Can only install one of: symfony/console[v2.1.10, v3.0.1].
    - Can only install one of: symfony/console[v2.1.11, v3.0.1].
    - Can only install one of: symfony/console[v2.1.12, v3.0.1].
    - Can only install one of: symfony/console[v2.1.13, v3.0.1].
    - Can only install one of: symfony/console[v2.1.2, v3.0.1].
    - Can only install one of: symfony/console[v2.1.3, v3.0.1].
    - Can only install one of: symfony/console[v2.1.4, v3.0.1].
    - Can only install one of: symfony/console[v2.1.5, v3.0.1].
    - Can only install one of: symfony/console[v2.1.6, v3.0.1].
    - Can only install one of: symfony/console[v2.1.7, v3.0.1].
    - Can only install one of: symfony/console[v2.1.8, v3.0.1].
    - Can only install one of: symfony/console[v2.1.9, v3.0.1].
    - Can only install one of: symfony/console[v2.2.0, v3.0.1].
    - Can only install one of: symfony/console[v2.2.1, v3.0.1].
    - Can only install one of: symfony/console[v2.2.10, v3.0.1].
    - Can only install one of: symfony/console[v2.2.11, v3.0.1].
    - Can only install one of: symfony/console[v2.2.2, v3.0.1].
    - Can only install one of: symfony/console[v2.2.3, v3.0.1].
    - Can only install one of: symfony/console[v2.2.4, v3.0.1].
    - Can only install one of: symfony/console[v2.2.5, v3.0.1].
    - Can only install one of: symfony/console[v2.2.6, v3.0.1].
    - Can only install one of: symfony/console[v2.2.7, v3.0.1].
    - Can only install one of: symfony/console[v2.2.8, v3.0.1].
    - Can only install one of: symfony/console[v2.2.9, v3.0.1].
    - Installation request for symfony/console == 3.0.1.0 -> satisfiable by symfony/console[v3.0.1].


Installation failed, reverting ./composer.json to its original content.

These are the versions I am running.

$ composer --version
Composer version 1.0-dev (d6ae9a0529e1f39c4c7f9b2f29fff019d79cd1fb) 2015-12-22 20:44:41
$ laravel --version
Laravel Installer version 1.3.1
$ php --version
PHP 5.5.30 (cli) (built: Oct 23 2015 17:21:45) 
$ vagrant --version
Vagrant 1.8.1
Ad

Answer

Needed to run

$ composer global require "laravel/homestead=~3.0"
Ad
source: stackoverflow.com
Ad