Ad

Because App Requires SDK Version >=2.15.1 <3.0.0, Version Solving Failed

- 1 answer

Can anyone tell me why am I getting this error?

The current Dart SDK version is 2.12.0.

Because app requires SDK version >=2.15.1 <3.0.0, version solving failed.
pub get failed (1; Because app requires SDK version >=2.15.1 <3.0.0, version solving failed.)

here is my flutter --version

Flutter 2.10.1 • channel stable • https://github.com/flutter/flutter.git
Framework • revision db747aa133 (2 days ago) • 2022-02-09 13:57:35 -0600
Engine • revision ab46186b24
Tools • Dart 2.16.1 • DevTools 2.9.2

Ad

Answer

You should not update the dart version of this project, please open pubspec.yaml file and update

environment: sdk: ">=2.12.0 <3.0.0"

to

environment: sdk: ">=2.16.0 <3.0.0"

Ad
source: stackoverflow.com
Ad